Wednesday, May 22, 2019

OSPF এরিয়া বডার রাউটার কনফিগারেশন

আমরা এর আগে বলেছিলাম যে OSPF এ দুটি বা ততোধিক রাউটার এক অপরের সাথে নেবার ও ডাটাবেজ একচেঞ্জ হওয়ার জন্য তাদেরকে একই এরিয়াতে থাকতে হবে । তারা যদি আলাদা আলাদা এরিয়াতে থাকে তাহলে তাদের মধ্যে নেবার বা ডাটাবেজ একচেঞ্জ হবে না । এরিয়া বডার রাউটিার এর মাধ্যমে আমরা আলাদা আলাদা এরিয়াকে কানেকটেড করতে পারি ।

এবার আসা যাক আমরা কি জন্য আলাদা আলাদা এরিয়া ব্যবাহার করব । যদি আমাদের নেটওয়ার্ক অনেক বড় হয়, সেখানে অনেকগুলি রাউটার থাকে, তাহলে প্রতিটি রাউরের অনেক পরিমান মেমরি লাগবে। কারণ তাদের ডাটাবেজটি অনেক বড় হবে। রাউটারের প্রসেসিং ক্ষমতাও বেশি লাগবে। প্রতিটি রাউটারের উপরে একটা অতিরিক্ত প্রেশার পরবে। আমরা সহজে এই সমস্য সমাধান করতে পারি, তা হল আলাদা আলাদা এরিয়াতে ভাগ করে ।আমরা জানি যে আলাদা আলাদা এরিয়ার রাউটারের মধ্যে কোন প্রকার ডাটাবেজ একচেঞ্জ হয় না । এখানে শুধু একই এরিয়ার রাউটার গুলির মধ্যে ডাটাবেজ একচেঞ্জ হবে। ফলে তাদের ডাটাবেজ টেবিলও ছোট হবে, মেমরিও কম লাগবে, রাউটারের প্রসেসিং ক্ষমতাও কম লাগবে। ফলে রাউটারের উপর একটি অতিরিক্ত প্রেশার পরে না ।

কিন্তু প্রশ্ন হল? আমরা এই আলাদা আলাদা এরিয়াকে কিভাবে কানেক্ট করব। খুব সহজ, আমরা এই আলাদা আলাদা এরিয়াকে কানেক্ট করার জন্য ব্যবহার করব এরিয়া বডার রাউটার ব্যবহার করব। এই এরিয়া বডার রাউটার আলাদা আলাদা এরিয়াকে কানেক্ট করে থাকে । উল্লেখযে, এই এরিয়া বডার রাউটারকে অবশ্যই বেশি পরিমান মেমরি ও প্রসেসিং ক্ষমতা সম্পন্ন হতে হবে। কারণ এই রাউটারে দুদিকের দুটি আলাদা আলাদা এরিয়ার সমস্থ রাউটারের ডাটাবেস তার কাছে থাকবে। এছড়াও আরো কিছু সমস্য আছে যার কারনে আমরা এরিয়া বডার রাউটার ব্যবহার করব। যেমন-


আমরা উপরের চিত্রের দিকে খেয়াল করি। এখানে আমদের ৯টা রাউটার রয়েছে । বুঝতেই পারতেছেন প্রতিটি রাউটারে একটি বিশাল পরিমান ডটাবেজ ক্রিয়েট হবে। হল কোন সমস্য নাই। কিন্তু আমরা ধরে নিলাম Route RA এর RA এইন্টারফেসটি ডাউন হয়ে যাচ্ছে এবং একটু পর আবার আপ হচ্ছে । এবং এই ভাবে একটু পর পর আপ এবং ডাউন হতে থাকে । যখন ইন্টারফেসটি ডাউন হয়ে তখন সাথে সাথে সেই রাউটার সকল রাউটারের কাছে একটি মেসেজ পাঠায়, ফলে সকল রাউটার তাদের ডাটাবেজ আপডেট করে নেয় । কিন্তু আবার যখন ইন্টারফেসটি আপ হয়ে যায় তখন সেই রাউটারটি আবার সকল রাউটারের কাছে তা জানিয়ে দেয়, ফলে আবার সকল রাউটার তাদের ডাটাবেজ আপডেট করে নেয়। এভাবে প্রতিবার তাদের ডাটাবেজ পরিবর্তন হতে থাবে। এর ফলে যে কোন সময় আমাদের যে কোন রাউটার ক্রাশ হওয়ার সম্ভাবনা থাকে ।



আমরা যদি এই রাউটার গুলিকে নিচের চিত্রের মত আলাদা আলাদা এরিয়াতে ভাগ করি তাহলে সমস্থ রাউটারকে এই ডাটাবেজ পরিবর্তন করতে হবে না । শুধু মাত্র এই পরিবর্তন এরিয়া 0 এর মধ্যে হবে । এরিয়া 1 এর মধ্যে কোনরুপ পরিবর্তন হবে না । এভাবে আমরা রাউটারের উপর কম চাপ প্রয়োগ করতে পারি।

এখন আমরা দেখব কিভাবে এই কনফিগারেশন করতে হয় । একটি কথা আমরা বলে রাখি রাউটার কোন এরিয়া এর মধ্যে থাকে না । রাউটার এর ইন্টারফেস সমুহ এরিয়ার এর মধ্যে থাকে ।
আমরা নিচের চিত্রের মত একিটি টপোলজি নিলাম এবং প্রথমে আমরা সকল রাউটার গুলির সকল ইন্টারফেসে আইপি অ্যাড্রেস দিয়ে এইন্টারফেস সমুহকে অন করে নিই।

Router 1 Configuration Code:

Router>en
Router#conf t
Router(config)#int fa 0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#int fa 0/1
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
Router(config)#int se 0/0/1
Router(config-if)#ip add 192.168.20.1 255.255.255.252
Router(config-if)#bandwidth 64000
Router(config-if)#no shut

Router 2 Configuration Code:

Router>en
Router#conf t
Router(config)#int se 0/0/1
Router(config-if)#ip add 192.168.20.2 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 6400
Router(config-if)#no shut
Router(config-if)#
Router(config-if)#int se 0/0/0
Router(config-if)#ip add 192.168.20.5 255.255.255.252
Router(config-if)#bandwidth 128
Router(config-if)#


Router 3 Configuration Code:

Router>en
Router#conf t
Router(config)#int se 0/0/0
Router(config-if)#ip add 192.168.20.6 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 128
Router(config-if)#no shut

Router(config-if)#int se 0/1/0
Router(config-if)#ip add 192.168.20.9 255.255.255.252
Router(config-if)#bandwidth 512
Router(config-if)#no shut

Router(config-if)#int se 0/0/1
Router(config-if)#ip add 192.168.20.13 255.255.255.252
Router(config-if)#bandwidth 512
Router(config-if)#no shut

Router 4 Configuration Code:

Router>
Router>en
Router#conf t
Router(config)#int se 0/0/0
Router(config-if)#ip add 192.168.20.14 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 512
Router(config-if)#no shut

Router 5 Configuration Code:

Router>en
Router#cofn t
Router(config)#int se 0/0/0
Router(config-if)#ip add 192.168.20.10 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 512
Router(config-if)#no shut

আমাদের সমস্থ রাউটার গুলিকে আইপি অ্যাড্রেস দেওয়া হল । এবার আমরা সমস্ত রাউটার গুলিতে OSPF রান করাব। এখানে আমরা যে কাজটি করব তা হল Router 1 এর সমস্থ ইন্টারফেস গুলিকে Area 0 তে রাখব এবং Router 3, Router 4, Router 5 এর সকল ইন্টারফেসকে Area 1 মধ্যে রাখব । আর Router 2 হচ্ছে আমাদের Area Border Router। সুতরাং এই রাউটারের Serial 0/0/1 এই ইন্টারফেসটি থাকবে Area 0 তে এবং Serial 0/0/0 এই ইন্টারফেসটি থাকবে Area 1 এর মধ্যে । আমরা এভাবে সকল রাউটারে OSPF রান করাই।

Router 1 Configuration Code:

Router>en
Router#conf t
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.20.0 0.0.0.3 area 0
Router(config-router)#

Router 2 Configuration Code:

Router>
Router>en
Router#conf t
Router(config)#router ospf 1
Router(config-router)#network 192.168.20.0 0.0.0.3 area 0
Router(config-router)#network 192.168.20.4 0.0.0.3 area 1
Router(config-router)#


Router 3 Configuration Code:

Router>
Router>en
Router#conf t
Router(config)#
Router(config)#router ospf 1
Router(config-router)#network 192.168.20.4 0.0.0.3 area 1
Router(config-router)#network 192.168.20.8 0.0.0.3 area 1
Router(config-router)#network 192.168.20.12 0.0.0.3 area 1

Router 4 Configuration Code:

Router>
Router>en
Router#conf t
Router(config)#router ospf 1
Router(config-router)#network 192.168.20.8 0.0.0.3 area 1
Router(config-router)#

Router 5 Configuration Code:

Router>
Router>en
Router#conf t
Router(config)#router ospf 1
Router(config-router)#network 192.168.20.12 0.0.0.3 area 1

আমরা সকল রাউটারের ইন্টারফেসগুলিকে আপ করলা এবং সেই সাথে সকল রাউটারে OSPF রান করালাম । এবার যদি আমরা Area 0 এর কোন রাউটার এর ডাটাবেজ চেক করি তাহলে সেখানে শুধু Aera 0 তে যে সকল রাউটার রয়েছে তাদের ডাটাবেজ দেখাবে, Area 1 এর কোন রাউটারের ডাটাবেজ থাকবে না । এবং যদি Area Border Router Router 2 এর ডাটাবেজ চেক করি তাহলে দেখবে সেখানে দুটি এরিয়া Area 0 & Area 1 এর সকল রাউটারের ডাটাবেজ থাকবে । চলুন আমরা Router 2 এর ডাটাবেজ চেক করি।

Router 2 Database Table:

Router#sh ip ospf database
OSPF Router with ID (192.168.20.5) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
192.168.20.1 192.168.20.1 324 0x80000004 0x00fcd4 4
192.168.20.5 192.168.20.5 303 0x80000003 0x0002a6 2

Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
192.168.20.4 192.168.20.5 293 0x80000001 0x00a7a6
192.168.20.8 192.168.20.5 218 0x80000002 0x002362
192.168.20.12 192.168.20.5 196 0x80000003 0x00f887

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count
192.168.20.5 192.168.20.5 233 0x80000002 0x00296b 2
192.168.20.10 192.168.20.10 83 0x80000002 0x002cee 2
192.168.20.13 192.168.20.13 31 0x80000006 0x009679 6
192.168.20.14 192.168.20.14 31 0x80000002 0x007c8e 2

Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum
192.168.20.0 192.168.20.5 298 0x80000001 0x00c88a
192.168.1.0 192.168.20.5 298 0x80000002 0x00b4ac
192.168.2.0 192.168.20.5 298 0x80000003 0x00a7b7
Router#

এখানে আমরা দেখতে পাচ্ছি যে Area 0 ও Area 1 এর আলাদা আলাদা ডাটাবেজ রয়েছে। অন্য রাউটারগুলিতে শুধু মাত্র ঐ এরিয়া ছাড়া অন্য কোন এরিয়ার ডাটাবেজ থাকেবে না । এভাবে আমরা বড় কোন নেটওয়ার্ককে অলাদা আলাদা এরিয়াতে ভাগ করতে পারি ।

Sunday, May 19, 2019

DR এবং BDR কি? DR এবং BDR কনফিগারেশন

এর আগে আমরা DR & BDR সম্পর্কে হালকা একটু আলোচনা করেছিলাম এবং বলেছিলাম যে, যদি দুটি রাউটার একে অপরের সাথে নেবার হয় তার পরেও তাদের মধ্যে ডাটাবেজ একচেঞ্জ নাও হতে পারে । পয়েন্ট টু পয়েন্ট কানেকশন এর ক্ষেত্রে নেবার হলেই তাদের মধ্যে ডাটাবেজ একচেঞ্জ হবে । কিন্তু মাল্টি একসেস নেটওয়ার্ক এর ক্ষেত্রে নেবার হলেও তাদের মধ্যে ডাটাবেজ একচেঞ্জ হবে না । এখানে DR এবং BDR নামে কিছু রাউটার থাকবে, শুধু মাত্র এই DR & BDR এর সাথে সমস্থ রাউটার ডাটাবেজ একসেঞ্জ করবে ।

BR & BDR

DR হচ্ছে Designated Router এবং BDR: Backup Designated Router। আমরা নিচের চিত্রের দিকে খেয়াল করি এটি একটি মাল্টি অ্যকসেস কানেকশন। এখানে রাউটারের একটি ইন্টারফেস দিয়ে একটি সুইচ এর মাধ্যমে অনকেগুলি রাউটার এর সাথে যুক্ত। পয়েন্ট টু পয়েন্ট কানেকশন এর ক্ষেত্রে রাউটারের একটি ইন্টারফেস দিয়ে অন্য একটি মাত্র রাউটার যুক্ত থাকে।

উপরের চিত্রের মত এই রকম মাল্টি অ্যাকসেস নেটওয়ার্ক এর ক্ষেত্রে প্রতিটি রাউটার ত একে অপরের সাথে Neighbors হবে কিন্তু Neighbors হওয়ার পরও তারা সকলে তাদের নিজেদের মধ্যে ডাটাবেজ একচেঞ্জ করবে না । Neighbors হওয়ার পর তাদের মধ্যে একটি ইলেকশন হবে । এই ইলেকশন এর মাধ্যমে একটি রাউটার হবে DR (Designated Router) এবং একটি রাউটার হবে BDR (Backup Designated Router) । এই DR & BDR এর সাথে অন্য সকল রাউটার তাদের ডাটাবেজ একচেঞ্জ করবে । তাছাড়া অন্য কোন রাউটার তাদের নিজেদের মধ্যে ডাটাবেজ একচেঞ্জ করবে না।


আমরা উপরের চিত্রটিতে লক্ষ করি। এখানে ৪টি রাউটার রয়েছে R1, R2, R3 এবং R4। যখন এদের মধ্যে OSPF রান করানো হল তখন এরা পরস্পর NEIGHBORS  হল, কোন সমস্য নাই । যেহেতু এটি একটি মাল্টি অ্যাকসেস নেটওয়ার্ক সেহেতু তাদের মাঝে একটি ইলেকশন হবে । ধরে নিলাম এখানে রাউটার R1 হল DR এবং রাউটার R4 হল DBR। এখন কি হবে রাউটার R2 এবং রাউটার R3 এর মাধ্যে কোন রকম ডাটাবেজ একচেঞ্জ হবে না । রাউটার R2 & R3 রাউটার R1 (DR) এবং রাউটার R3 (BDR) এর সাথে ডাটাবেজ একচেঞ্জ করবে । কোন কারণে যদি DR ফেইল হয়ে যায় তখন  আবার নতুন করে এদের মধ্যে ইলেকশন হবে তখন BDR হয়ে যাবে DR এবং অন্য কোন একটি রাউটার হবে BDR।

এখন প্রশ্ন হলে এই যে DR & BDR নির্বাচন হচ্ছে তা কিসের উপর ভিত্তি করে হচ্ছে । আমরা সকলেই জানি রাউটার প্রায়োরিটি বলে কিছু একটা রয়েছে । আমরা অগেই বলেছিলাম যে এই রাউটার প্রায়োরিটি পয়েন্ট টু পয়েন্ট নেটওয়ার্ক এর ক্ষেত্রে তেমন কোন কাজে লাগে না কিন্তু মাল্টি অ্যাকসেস নেটওয়ার্ক  এর ক্ষেত্রে এই রাউটার প্রায়োরিটি কাজে লাগে । এই  রাউটার প্রায়োরিটির উপর ভিত্তি করে এই DR এবং BDR নির্বাচন হয়ে থাকে । যখন এই ইলেকশন হয়, তখন যে রাউটারের প্রায়োরিটি সবচেয়ে বেশি থাকে সেই হয়ে যায় DR এবং যে রাউটারের প্রায়োরিটি তার চেয়ে কম থাকে সে হয়ে যায় BDR। এখানে আরো একটি বিষয় মনে রাখার দরকার যে একবার যখন DR & BDR নির্বাচন হয়ে যায় তার পর যদি এর চেয়ে আরো ভাল প্রায়োরিটির কোন রাউটার যদি নেটওয়ার্ক এ যুক্ত হয় তাহলেও সে DR বা BDR হবে না । তবে কিছু সিস্টেম আছে যা ব্যবহার করে যে কোন রাউটারকে ইচ্ছেমত DR বা BDR বানানো যায় ।

রাউটার প্রায়োরিটি কিন্তু ইচ্ছামত চেঞ্জ করা যায় । আর এই প্রায়োরিটি চেঞ্জ করেই আমরা যেকোন রাউটারকে DR বা BDR বানাতে পারি । আমরা যদি চাই যে স্পেসিফিক কোন রাউটার DR & BDR নির্বাচনে অংশগ্রহন না করুক। এ ক্ষেত্রে আমাদের যে কাজটি করতে হবে তা হল যে রাউটাটিকে নির্বাচনে অংশগ্রহন করাব না তার প্রায়োরিটি শুন্য করে দিব । তাহলে আর সেই রাউটারটি আর নির্বাচনে অংশগ্রহন করবে না । কারণ যে রাউটার এর প্রায়োরিটি শুন্য থাকে সে DR & BDR নির্বাচনে অংশগ্রহন করতে পারে না ।


আমরা উপরের চিত্রের মত একটি মাল্টি অ্যাকসেস নেটওয়ার্ক নিলাম যেখানে চারটি রাউটার একটি সুইচ এর মাধ্যমে যুক্ত। আমরা জানি যে মাল্টিপয়েন্ট কানেকশন এর ক্ষেত্রে একটি রাউটার একসাথে অনেকগুলি রাউটারের সাথে যুক্ত থাকে । এই রকম মাল্টি পয়েন্টে কানেকশন এর ক্ষেত্রে ঐ টপোলজিতে যতই রাউটার থাকুন না কে সেখানে একটি রাউটার হবে DR এবং একটি রাউটার হবে BDR। অন্য সকল রাউটার শুধু মাত্র এই DR এবং BDR এর সাথে ডাটাবেজ একচেঞ্জ করবে। DR & BDR ছাড়া অন্য কোন রাউটারের সাথে তারা ডাটাবেজ একচেঞ্জ করবে না । যদিও আমরা পয়েন্ট টু পয়েন্ট কানেকশন এর ক্ষেত্রে দেখেছিলাম যে যদি কোন রাউটার একে অপরের সাথে NEIGHBORS  হয় তাহলে তাদের মধ্যে ডাটাবেজ একচেঞ্জ হবে।

চলুন প্রথমে আমরা সকল রাউটার সমুহের ইন্টারফেস গুলিকে আইপি অ্যাড্রেস দিয়ে  আপ করে নিই। নিচে ইন্টারফেস গুলিকে আইপি দিয়ে আপ করার কমান্ড সমুহ দেওয়া হল ।

Router 1 Configuration Code: 

Router>
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa 0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router 2 Configuration Code:

Router>
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa 0/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router 3 Configuration Code:

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa 0/0
Router(config-if)#ip add 192.168.1.3 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router 4 Configuration Code:

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa 0/0
Router(config-if)#ip add 192.168.1.4 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

আমাদের সকল রাউটার সমুহের ইন্টারফেস সমুহ গুলিকে কনফিগার করা হয়ে গেল । এবার আমরা সকল রাউটার সমুহে OSPF কনফিগার করব। ত চলুন আমরা OSPF কনফিগার করি।

Router 1 Configuration Code:

Router>
Router>en
Router#conf t
Router(config)#route ospf 1
Router(config-router)#network 192.168.1.1 0.0.0.0 area 1
Router(config-router)#

এখানে আমরা ওয়াইলকার্ড ম্যক্স হিসেবে 0.0.0.0 ব্যবহার করেছি। কারণ Router 1 এর এই ইন্টারফেস শুধুমাত্র এই একটি আইপি অ্যাড্রেস চলবে । আমরা এই টপোলজিতে সকল রাউটারে ওয়ালকার্ড ম্যাক্স হিসেবে 0.0.0.0 ব্যাবহার করব । তাহলে যা হবে আমরা যদি এই সুইচটাতে কোন পিসি যুক্ত করি তাহলেও সে নেটওয়ার্ক অ্যাকসেস করতে পারবে না । কিন্তু আমরা যদি এখানে ওরিজিনাল ওয়াইলকার্ড ম্যাক্স 0.0.0.255 ব্যাবহার করতাম তাহলে যে কেউ এই সুইচে একটি পিসি যুক্ত করে 192.168.1.1-254 পর্যন্ত যে কোন একটি আইপি অ্যাড্রেস দিলে সে সহজেই নেটওয়ার্ক অ্যাকসেস করতে পারবে।

Router 2 Configuration Code:

Router>
Router>en
Router#conf t
Router(config)#route ospf 1
Router(config-router)#netw 192.168.1.2 0.0.0.0 area 1
Router(config-router)#

Router 3 Configuration Code:

Router>en
Router#conf t
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.3 0.0.0.0 area 1
Router(config-router)#

Router 4 Configuration Code:

Router>
Router>en
Router#conf t
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.4
Router(config-router)#network 192.168.1.4 0.0.0.0 area 1
Router(config-router)#

আমাদের সকল রাউটারে OSPF কনফিগার করা হয়ে গেল। এবার আমরা কোন রাউটারে গিয়ে তার ডাটাবেজ, NEIGHBORS  ও রাউটিং টেবিল চেক করি। রাউটার 1 এ চেক করে দেখি যে কোন রাউটার DR & BDR হয়েছে । sh ip ospf interface আমরা এই কমান্ডটি ব্যবহার করে দেখতে পারি, কোন রাউটার DR এবং BDR হয়েছে ।

Router#sh ip ospf interface

FastEthernet0/0 is up, line protocol is up
Internet address is 192.168.1.1/24, Area 1
Process ID 1, Router ID 192.168.1.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DROTHER, Priority 1
Designated Router (ID) 192.168.1.4, Interface address 192.168.1.4
Backup Designated Router (ID) 192.168.1.3, Interface address 192.168.1.3
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:02
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 3, Adjacent neighbor count is 2
Adjacent with neighbor 192.168.1.4 (Designated Router)
Adjacent with neighbor 192.168.1.3 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
Router#

আমরা এখানে দেখতে পাচ্ছি যে DR হয়েছে Router (ID) 192.168.1.4 এই রাউটারটি এবং BDR হয়েছে Router (ID) 192.168.1.3 এই রাউটার টি । আমরা অগেই বলেছিলাম যে প্রতিটি রাউটার এর একটি Router ID থাকে । আর এই Router ID তিন ভাবে নির্ধারণ হয়ে থাকে ।

          ১. Administrator চাইলে এটি নিজে নিজে অ্যসাইন করে দিতে পারে ।

আর যদি অ্যাডমিনেসট্রেটর এটি অ্যাসাইন করে না দেয় তাহলে:-

            ২. Highest IP address on the loopback interface.

লুপব্যক ইন্টারফেস হল একটি ভর্চুয়াল ইন্টাফেস। এটি কোন ফিজিক্যল ইন্টারফেস না । আমরা চাইলে রাউটারে লুপব্যাক ইন্টারফেস ক্রিয়েট করতে পারি । যদি রাউটারে কোন লুপব্যক ইন্টারফেস না থাকে তাহলে

            ২. Highest IP Address on the physical interface

রাউটারের যেসকল ফিজিক্যাল ইন্টারফেস অ্যকটিভ থাকবে, তার মধ্যে যে ইন্টারফেস এর আইপি অ্যাড্রেটি সবচেয়ে বড় সেটিই রাউটার আাইডি হিসেবে নিধ্যারণ করে নিবে।

এখানে যেহেতু আমরা নিজে কোন Router ID ডিফাইন করে দিই নাই বা কোন লুপব্যাক ইন্টাফেও ক্রিয়েট করি নাই তাই রাউটার নিজেই তার ফিজিক্যাল ইন্টারফেস এর মধ্যে যে আইপি অ্যাড্রেসটি সবচেয়ে বড় সেটিই তার রাউটার আইডি হিসেবে নির্ধারণে করে নিয়েছে । সুতবাং এখানে আমরা দেখতে পাচ্ছি যে Router 4 হয়েছে DR এবং Router 3 হয়েছে BDR যেটা আমাদের হওয়ার কথা ছিল । কারণ আমরা জানি যে যে রাউটার এর প্রায়োরিটি সবচেয়ে বেশি সেটি হবে DR এবং যেটার প্রায়োরিটি তার DR এর চেয়ে কম হবে সেটি হবে BDR। আর যদি সকল রাউটার এর প্রয়োরিটি সমান হয়ে তাহলে যে Router ID সবচেয়ে বড় হবে সে হবে DR এবং যার সেকেন্ড হবে সে হবে BDR।


এবার আমরা যদি চাই যে কোন রাউটার যদি DR & BDR হবে না ।  তাহলে আমরা সেই রাউটারের প্রায়োরিটি 0 করে দিবে তাহলে সেটি আর কখোন DR বা BDR হতে পারবে না । কারণ সেটি DR এবং BDR নির্বাচনে অংশগ্রণ করতেই পারবে না । আর যদি আমরা চাই যে নির্দিষ্ট কোন রাউটারকে DR বানাব তাহলে সেই রাউটারের প্রায়োরিটি সবচেয়ে বেশি করে দিব  । এবং এর পর প্রথমে DR এবং এর পরে BDR রাউটারকে রিস্টার্ট দিব । তহলেই বেশি প্রায়োরিটির রাউটারটি হবে DR । আজ তাহলে এই পর্যন্ত, আশা করি আপনার DR এবং BDR সম্পর্কে খুব ভাল একটি ধারণা পেয়েছেন।

Thursday, May 16, 2019

মোবাইল ফোন নেটওয়ার্ক যেভাবে কাজ করে

আজকে আমরা দেখব মোবাইল ফোন নেটওয়ার্ক কিভাবে কাজ করে।মোবাইল ফোন কিভাবে কাজ করে তার হিশেব নিকেশ অনেক বেশি এবং কিছুটা জটিল বটে তবে আমি আজকে মোবাইল ফোনের নেটওয়ার্ক কিভাবে কাজ করে তার একটা সহজ এলগরিদম ব্যাখ্যা করব।
                                               


মোবাইল নেটওয়ার্কে কয়েক ধরনের প্রযুক্তির মধ্যে (GSM,CDMA,TDMA,FDMA etc) আমাদের দেশে মুলত ২ই ধরনের প্রযুক্তি ব্যবহার হয়-
  •  GSM (Global System for Mobile Communication) (যেমনঃ টেলিটক, বংলালিংক, জিপি, রবি, এয়ারটেল)
  • CDMA (Code Division Multiple Access) (সিটিসেল একমাত্র CDMA অ্পারেটর)
          (GSM এবং CDMA  কিভাবে কাজ করে তার জন্য পরবর্তীতে আরেকটি আর্টিকেল লিখব যেখানে ২ই প্রযুক্তির সুবিধা এবং অসুবিধা ব্যাখ্যা করব)

আমাদের দেশে ৬ টি মোবাইল অপারেটরের প্রায় ৩০ হাজার মোবাইল টাওয়ার আছে।এখন প্রশ্ন হতে পারে যে এত টাওয়ার কেন দরকার যেখানে রেডিও কিংবা টেলিভিশনের ক্ষেত্রে ২,৩ টা টাওয়ারই যথেষ্ট? তার উত্তর হচ্ছে প্রযুক্তিগত দিক থেকে মোবাইল নেটওয়ার্ক হচ্ছে ফুল ডুপ্লেক্স(অর্থাৎ একই সাথে দুই দিকে ব্রডকাস্ট)রেডিও কিংবা টেলিভিশন মোবাইল নেটওয়ার্ক থেকে ভিন্ন কারন রেডিও ,টিভি হচ্ছে সিমপ্লেক্স (একমুখী ব্রডকাস্ট) আর যার জন্য আমরা শুধু রেডিও তে আরজেদের বকবকানি শুনি বা টিভি তে অনুষ্ঠান দেখি। যদি মোবাইল সিমপ্লেক্স  ব্রডকাস্ট  হতো  তাইলে সবার কথা সবাই শুনে ফেলত এবং প্রচুর নয়েজ হত।

মোবাইল ফোন নেটওয়ার্ক এর আর্কিটেকচারটা শুরুতে একটু দেখে নেয়া যাকঃ

মোবাইল নেটওয়ার্কের  টাওয়ার সেট করার জন্য ষড়ভুজ আকৃতির ডায়াগ্রাম ব্যবহার করা হয়

                                   

মোবাইল নেটওয়ার্কে কোন দেশ বা এরিয়াকে হাজার হাজার সেলে বিভক্ত করা হয। প্রত্যেক সেলের জন্য বি.টি.এস থাকে। আবার বি.টি.এসকে সাপোর্ট দেয়ার জন্য অনেক সময় অপারেটররা মাইক্রো বি.টি.এস ব্যবহার করে থাকে। বি.টি.এস কেবল এরিয়ার আয়তন হিসেবে বসানো হয়না। কোন স্থানে কতগুলো বি.টি.এস বসবে তা ওখানকার মোবাইল ব্যবহারকারীর সংখ্যার উপরও নির্ভর করে থাকে।

 BTS কোন সেল ফোন থেকে আগত রিকোয়েষ্টকে তাদের MSC-তে (মোবাইল সুইচিং সিস্টেম) পাঠায়।MSC-তে VLR (ভিজিটর লোকেটর রেজিষ্টার) থাকে। সেই VLR এ ইউসারের ইনফরমেশান থাকে। অর্থাৎ কোন VTS এর অধিনে কোন কোন ইউসার আছে। এটা টেম্পরারী থাকে।
যদি আপনি একই অপারেটরের অধিনস্ত মোবাইলে কল করে থাকেন তাহলে একই পদ্ধতিতে তা আবার রিসিভারের মোবাইলে যাবে। অর্থাৎ এইচ,এল.আর থেকে ভি.এল আর তারপর বি.টিএস এ এরপর সেলফোন এ যাবে।

যদি আপনি অন্য কোন অপারেটরের মোবাইলে কল করে থাকেন তাহলে HLR তাদের গেটওয়ের মাধ্যমে SS7 প্রোটোকল ইউস করে অন্য অপারেটরের HLR এ রিকোয়েষ্ট পাঠাবে।




















এর চাইতে একটু সহজ করে যদি দেখি তাহলে, আর্কিটেকচারটা নিচের মত দেখাবেঃ


আমরা যখন একটি সেল ফোন থেকে আরেকটি সেল ফোন থেকে কল করার চেষ্টা করি তখন সেল ফোন প্রথম BTS এ রিকোয়েষ্ট পাঠায়। বাংলাদেশে GSM এর ক্ষেত্রে তা ৯০০ থেকে ১৮০০ ফ্রিকুয়েন্সী রেঞ্জের ভিতর হয়ে থাকে। BTS এর কাজ হল ট্রান্সমিশান সেন্ড ও রিসিভ করা।

                                    মোবাইল ফোন নেটওয়ার্ক এর আর্কিটেকচার

Radio Access Network (RAN)

আমরা যখন কাউকে কল করি তখন তা আমাদের মোবাইল ফোন থেকে বাতাসের মধ্য দিয়ে সরাসরি নিকটস্থ কোন একটা BTS টাওয়ারে যায় আর  এই টাওয়ার বা BTS গুলোকে কন্ট্রোল করে BSC (Base Station Controller). এক একটা BSC প্রায় ১৫০-২০০ BTS কে কন্ট্রোল করতে পারে। আর এই BTS এবং BSC গুলো মিলেই গড়ে উঠে গোটা মোবাইল নেটওয়ার্ক এর সবচেয়ে বড় নেটওয়ার্ক – Radio Access Network (RAN).

Switching Network OR Core Network:


যারা পূর্বের T&T (বর্তমান BTCL) এর এক্সচেঞ্জ (Telephone Exchange) এর সাথে পরিচিত আছেন, তারা জানেন যে, T&T তে কল করলে প্রথমে একজন অপারেটর কল ধরত এবং আপনার কাছে এক্সটেনশন নাম্বার জিজ্ঞেস করত। এবং সে আপনার কাংখিত এক্সটেনশন নাম্বার এ সংযোগ দিয়ে দিত। অর্থাৎ সুইচিংটা সে করে দিত।
এখন একটু ভাবুন তো, প্রতি দিন মোবাইল টু মোবাইল এ যে পরিমান কল হয়, তা যদি অপারেটর দিয়ে এক্সচেঞ্জ করতে হত, তাহলে কত কোটি অপারেটর লাগত???
মোবাইল ফোন নেটওয়ার্ক এ এই এক্সচেঞ্জ এর কাজটি করে দেয় Mobile Switching Center (MSC).

Intelligent Network:

এবার আসি Intelligent Network (IN) এ। আমাদের দুই ধরনের কানেকশন পাওয়া যায়
  • ক) প্রি-পেইড
  • খ) পোস্ট-পেইড
যারা প্রি-পেইড ইউজার তাদের মোবাইল এ balance/টাকা আছে কিনা, সে বৈধ ইউজার কিনা, সে যে Service টা ব্যবহার করতে চাচ্ছে তার জন্য Registration করা আছে কিনা এর সব জন্য সংরক্ষিত থাকে IN এ। আপনার কল সংযোগ দেয়ার আগেই এই সমস্ত খোঁজ খবর নিয়েই আপনাকে কল করার অনুমতি দেয়া হয়।

Transmission Network


Transmit করা মানে হচ্ছে কোন কিছু এক জায়গা থেকে অন্য জায়গায় পাঠানো। মোবাইল ফোন আমাদের কথা(Voice) অথবা Data (SMS/Internet/Multimedia Data) নিয়ে কাজ করে। আর আমাদের এই কথা (Voice) অথবা Data (SMS/Internet/Multimedia Data) স্থানান্তর অর্থাৎ যাকে কল করছেন তার কাছে পৌছে দেয়ার জন্য মাধ্যম হিসেবে কাজ করে Transmission Network।
  • ১। Radio Access Network (RAN)  মোবাইল ফোন সরাসরি এই নেটওয়ার্ক এর সাথে যোগাযোগ করে
  • ২। Switching Network বা Core Network  যাকে কল করছেন তার কাছে সুইচিং করে দেয় বা সংযোগ স্থাপন করে দেয়
  • ৩। Intelligent Network (IN) মোবাইল ইউজার এর সব তথ্য জমা রাখে এবং Verify করে
  • ৪। Transmission Network  তথ্য আদান প্রদান এর মাধ্যম হিসেবে কাজ করে.

Wednesday, May 15, 2019

ডায়নামিক রাউটিং (OSPF) কি এবং কিভাবে কাজ করে বিস্তারিত

OSPF কি?

OSPF এর পূর্ণরূপ হলো Open Shortest Path First । এটি একটি Link State রাউটিং প্রটোকল যা Distance Vector রাউটিং প্রটোকল RIP এর রিপ্লেসমেন্ট হিসেবে এসেছে। OSPF ডেভেলপ করার কাজ শুরু হয় 1987 সালে IETF এর মাধ্যমে। 1989 সালে OSPFv1 (Version 1) আবির্ভূত হয়, যা ছিল পরীক্ষামূলক। 1991 সালে OSPFv2 (Version 2) আসে। পরবর্তীতে 1999 সালে IPv6 এর জন্য OSPFv3 (Version 3) উন্মুক্ত হয়।

OSPF একটি Open Standard, Link State, লুপ ফ্রি Routing Protocol। Open Standard মানে হচ্ছে এটি যেকোন ভেন্ডর / কোম্পানির রাউটারে রান করানো যাবে । Cisco ছাড়াও অন্য যেকান কোম্পানির রাউটারে এই প্রটোকলটি রান করানো যাবে । Link State রাউটিং প্রটোকলসমূহ Shortest Path First (SPF) এ্যালগরিদমের মাধ্যমে রাউট ক্যালকুলেশন করে থাকে। এই SPF এ্যালগরিদমটি Edsger Dijkstra নামক একজন ব্যাক্তি লিখেছিলেন। এজন্য SPF কে Dijkstra’s Algorithm (ডাইজ্কস্ট্রা’স এ্যালগরিদম) ও বলা হয়। এই এ্যালগরিদমের মাধ্যমে একটি সোর্স নেটওয়ার্ক থেকে কোন একটি ডেস্টিনেশন নেটওয়ার্কে যাওয়ার সম্ভাব্য প্রতিটি পাথকে Cost সহ হিসেব করা হয়।

যখন কোন রাউটারে OSPF রান করানো হয় তখন সে তিনটি কাজ করে । আমরা একে OSPF এর ফিচার বা বৈশিষ্টও বলতে পারি । যথা:
  • Neighbor Relation
  • Database Exchange
  • Route Calculation
যে সকল রাউটারে OSPF রান করে সে সকল রাউটারে এই তিনটি টেবিল থাকে। যখন একটি রাউটার আর একটি রাউটার এর সাথে নেবার রিলেশনশিপ স্থাপন কারে তখন তাদের মাঝে একটি Neighbor Table। নেবার রিলেশনশিপ স্থাপন হওয়ার পর তাদের মাঝে ডাটাবেজ এক্সচেঞ্জ হবে, তখন একটি Database Table তৈরি হবে এবং সবশেষে যখন রুট কালকুলেট হবে তখন একটি Routing Table তৈরি হবে। এই তিনটি টেবিল দেখার জন্য যে কোড ব্যবহার করা হয় তা নিচে দেখানো হল ।
  • Neighbor Tabel ( show ip ospf neighbor)
  • Database Exchange ( show ip ospf data base)
  • Route Calculation ( show ip route)

 OSPF Neighbor

নেবার রিলেশনশিপ এর মাধ্যমে রাউটার তার প্রতিবেশি রাউটার সম্পর্কে জানতে পারে । রিপে আমরা দেখেছিলাম প্রতিটি রাউটার শুধুমাত্র তার প্রতিবেশি রাউটার সম্পর্কে জানতে পারে এবং তার উপর ভিত্তি করে তার রাউটিং টেবিল তৈরি করে থাকে । কিন্তু OSPF এর ক্ষেত্রে নেটওয়ার্কে যতগুলি রাউটার থাকে সমস্থ রাউটার এর সাথে সে নেবার রিলেশনশিপ স্থাপন করে, সেই সাথে প্রতিটি রাউটারের ইনফরমেশন প্রতিটি রাউটার এর কছে থাকে । এই ইনফরমেশন গুলির জন্য সে একটি Neighbor Table তৈরি করে ।

কোন রাউটারে যে OSPF রান করলেই যে প্রতিটি রাউটার এক অপরের সাথে নেবার হবে তা কিন্তু না। প্রতিটি রাউটার একে অপরের সাথে নেবার হওয়ার জন্য কিছু প্যারামিটার আছে সেই প্যারামিটার মিললেই একে অপরের সাথে নেবার রিলেশনশিপ স্থাপন করে । তাছাড়া তারা নেবার হবে না ।

এখন প্রশ্ন হল কিভাবে এই নেবার রিলেশনশীপ স্থাপন হয়? যখন কোন রাউটারে OSPF রান করানো হয় তখন সে তার সমস্থ আকটিভ ইন্টারফেস দিয়ে একটি Hello Message Send করে। এই Hello Message একটি প্রতি 10 Second পর পর প্রতিটি রাউটারের কাছে send করতে থাকে। এই hello message এর মধ্যে কি থাকে? এই Hello Message এর মধ্যে যে সকল কনটেন থাকে তা হল
  • Hello Message Contains:-
  • Router ID (32 bit)
  • Area ID
  • Hello Interval
  • Dead Interval
  • Router Priority
  • The Router ID of the Designated Router (DR)
  • The Router ID of the Back-up Designated Router (BDR)
  • A list of neighbor, the sending router already knows about the subnet.
নিচে এই প্যারামিটারগুলি সম্পর্কে বিস্তারিত আলোচনা করা হল।

Router ID:প্রতিটি রাউটার এর একটি রাউটার আইডি থাকে। এই আইডিটি 32bit এর হয়ে থাকে । যেমন :- Router ID ------1.1.1.1 প্রতিটি রাউটারের কিন্তু এই রাউটার আইডি আলাদা আলাদা । কখোন দুটি রাউটারের রাউটার আইডি একই হবে না । কিছু ক্রাইটেরিয়া রয়েছে যার উপর ভিত্তি করে এই রাউটার আইডি নির্ধারণ করে থাকে ।

           ১. Administrator চাইলে এটি নিজে নিজে অ্যসাইন করে দিতে পারে ।

আর যদি অ্যাডমিনেসট্রেটর এটি অ্যাসাইন করে না দেয় তাহলে:-

            ২. Highest IP address on the loopback interface.

লুপব্যাক ইন্টারফেস হল একটি ভর্চুয়াল ইন্টাফেস। এটি কোন ফিজিক্যল ইন্টারফেস না । আমরা চাইলে রাউটারে লুপব্যাক ইন্টারফেস ক্রিয়েট করতে পারি । যদি রাউটারে কোন লুপব্যক ইন্টারফেস না থাকে তাহলে

            ২. Highest IP Address on the physical interface

রাউটারের যেসকল ফিজিক্যাল ইন্টারফেস অ্যকটিভ থাকবে, তার মধ্যে যে ইন্টারফেস এর আইপি অ্যাড্রেটি সবচেয়ে বড় সেটিই রাউটার আাইডি হিসেবে নিধ্যারণ করে নিবে।

Area ID: OSPF এ প্রতিটি রাউটার এর একটি এরিয়া আইডি থাকে। এর মান আমরা ডেসিমেল ভালু বা আইপি অ্যাড্রেস এই দুই ভাবে দিতে পরি ।

Router Priority: প্রতিটি রাউটার এর একটি প্রায়োরিটি থাকে। এই রাউটার প্রায়োরিটি এর মান 1-255 পর্যন্ত যে কোন মান হতে পারে । এই রাউটার প্রায়োরিটি পয়ন্ট টু পয়েন্ট কানেকশন এর সময় তেমন কাজে লাগে না তবে মাল্টিঅ্যাক্সেস নেটওয়ার্ক এর ক্ষেত্রে এই রাউটার প্রায়োরিটি কাজে লাগে। ডিফল্ট ভাবে এই রাউটার প্রায়োরিটি 1 হয়ে থাকে।

Hello Interval: রাউটার কত সময় পর পর Hello message send করে তাবে বলা হয় Hello Interval. এই Hello Interval টাইম দুই দিকের রাউটার এর একই হতে হবে তাছাড়া তাদের মধ্যে নেবার রিলেশনশীপ স্থাপন হবে না ।

Dead Interval: কতক্ষন সময় এর মধ্যে যদি কোন hello message না আসলে তাদের রাউটার বুঝতে পারবে যে ঐ লিংকটি ডাউন হয়ে গেছে সেই সময়টাকে বলে Dead Interval । রাউটারের দুদিকের Dead interval একই হতে হবে।

BR & BDR: মাল্টিঅ্যাক্সেস নেটওয়ার্ক এর ক্ষেত্রে একটি রাউটার Designated Router এবং আর একটি রাউটার Backup Designated Router হয়ে থাকে । কে Designate Router এবং কে Backup Designated Route হবে তা নির্ভর করে রাউটার প্রায়োরিটি এর উপর । পরবর্তিতে BR & BDR সর্ম্পকে বিস্তারিত আলোচনা করা হবে।

প্রতিটি রাউটার একে অপরের সাথে নেবার হওয়ার জন্য যে সকল কনডিশন একই হতে হবে তা হল:-
  • Area ID
  • Subnet Musk use on the subnet
  • Hello Interval
  • Router Must Password Authentication Check
  • Dead Interval
  • Value of Stub area flag

প্রতিটি রাউটারের মধ্যে যদি এই কনডিশন গুলি ম্যাচ করে তহলে তাদের মধ্যে নেবার রিলেশনশীপ স্থাপন হবে। তাছাড়া তাদের মধ্যে কোন নেবার রিলেশনশিপ হবে না ।

Database Exchange

প্রতিটি রাউটার এর মধ্যে যখন Neighbor Relation স্থাপন হয়ে যাবে । সকল রাউটারের কাছে যখন প্রতিটি রাউটারের ইনফরমেশন চলে গেল এবার তাদের মধ্যে ডাটাবেজ এক্সচেঞ্জ হবে। এই ডাটাবেজ টা অসলে কি? এই ডাটাবেজ এর মধ্যে রাউটার এর প্রতিটি ইন্টারফেস এর ইনফরমেশন থাকে।রাউটারে কি কি ইন্টারফেস আছে, সেই ইন্টারফেসে কি কি নেটওয়ার্ক চলে, তাদের বান্ডউইথ কত এবং সেটি আপ না ডাউন ইত্যদি ইনফরমেশন থাকে । অর্থাৎ রাউটারের প্রতিটি লিংক এর সমস্থ ইনফরমেশন তার নেইবার এর কাছে পাঠাবে । রাউটার এর ডাটাবেজ টেবিল দেখার জন্য যে কমান্ডটি ইউজ করা হয় তা হল ‍show ip ospf data base. এই কমান্ডটি ব্যবহার করে আমরা রাউটারের ডাটাবেজ টেবিল দেখতে পারি ।

BR & BDR: DR হচ্ছে Designated Router এবং BDR: Backup Designated Router। আমরা নিচের চিত্রের দিকে খেয়াল করি এটি একটি মাল্টি অ্যকসেস কানেকশন। এখানে রাউটারের একটি ইন্টারফেস দিয়ে একটি সুইচ এর মাধ্যমে অনকেগুলি রাউটার এর সাথে যুক্ত। পয়েন্ট টু পয়েন্ট কানেকশন এর ক্ষেত্রে রাউটারের একটি ইন্টারফেস দিয়ে অন্য একটি মাত্র রাউটার যুক্ত থাকে।

উপরের চিত্রের মত এই রকম মাল্টি অ্যাকসেস নেটওয়ার্ক এর ক্ষেত্রে প্রতিটি রাউটার ত একে অপরের সাথে নেবার হবে কিন্তু নেবার হওয়ার পরও তারা সকলে তাদের নিজেদের মধ্যে ডাটাবেজ একচেঞ্জ করবে না । নেবার হওয়ার পর তাদের মধ্যে একটি ইলেকশন হবে । এই ইলেকশন এর মাধ্যমে একটি রাউটার হবে DR (Designated Router) এবং একটি রাউটার হবে BDR (Backup Designated Router) । এই DR & BDR এর সাথে অন্য সকল রাউটার তাদের ডাটাবেজ একচেঞ্জ করবে । তাছাড়া অন্য কোন রাউটার তাদের নিজেদের মধ্যে ডাটাবেজ একচেঞ্জ করবে না ।

Route Calculation

যখন প্রতিটি রাউটার একে অপরের সাথে নেবার হওয়ার পর ডাটাবেজ একচেঞ্জ হয়ে গেলে এবার রাউটার রুট কালকুলেশন এর কাজ করে । রুট কালকুলেশন এর কাজ রাউটার নিজেই করে থাকে । এর জন্য আমাদের আর কিছু করতে হবে না ।

এখন প্রশ্ন হল OSPF কিভাবে রুট কালকুলেশন করে থাকে । রিপ এর ক্ষেত্রে আমরা দেখেছিলাম, রিপ হপ কাউন্ট এর উপর ভিত্তি করে ‍রুট কালকুলেশন করে থাকে। যে পথে সে সবচেয়ে কম রাউটার পায় সেই পথে সে ডাটা রাউটিং করে থাকে । কিন্তু OSPF এর ক্ষেত্রে রুট কালকুলেশন হয়ে থাকে তাকে আমরা বলি Cost। আর এই Cost নির্ধারণ হয়ে থাকে  ব্যান্ডউইথ এর উপর ভিত্তি করে ।  OSPF এ এই নির্ধারণের একটি সুত্র আছে আর সেই সুত্রটি হল Cost=  । 108/bandwidth এই সুত্রের সাহায্য OSPF রুট নির্ধারণ করে থাকে। যে পথের Cost সবচেয়ে কম হবে সেই পথটি ডাটা রাউটিং এর জন্য নির্ধারণ করা হয়।



আমরা উপরের চিত্রের দিকে খেয়াল করি এখানে এখানে একটি টপোলজি আছে যেখানে রাউটার R2 এর সাথে রাউটার  R1 & R3 সিরিয়াল ক্যাবল এর মাধ্যমে পয়েন্ট টু পয়েন্ট কানেকশনে যুক্ত এবং রাউটার R1, R3 & R4 একে অপরের ইথারনেট ক্যবাল এর মাধ্যমে মাল্টি অ্যাকসেস টপোলজিতে যুক্ত । এখানে রাউটার R1, R3 & R4 এর Cost হল  10। এবং রাউটার R1 থেকে রাউটার R2 এর Cost হল 100। এবং রাউটার R3 থেকে রাউটার R2 এর Cost হল 64। রাউটার R2 থেকে 100.100.100.100 এই নেটওয়ার্কে যেতে Cost হল 10। এখন যদি রাউটার R4 100.100.100.100 নেটওয়ার্কে যেতে চায়, তাহলে সে দুটি পথে সেখানে যেতে পারে । একটি পথ হল R4>R1>R2>100.100.100.100 এই পথেরে Cost হবে 10+100+10=120। এবং আর একটি পথ হল R4>R3>R2=100.100.100.100 এই পথের Cost হবে 10+64+10=84। দেখা যাচ্ছে যে এই পথেরে Cost সবচেয়ে কম সুতরাং এই রুটটি রাউটার ডাটা রাউটিং এর জন্য বেছে নিবে। OSPF এভাবে রুট কালকুলেশন করে থাকে।

 OSPF Bangla Tutorial


ডায়নামিক রাউটিং(OSPF) কি এবং কিভাবে কনফিগার করতে হয়?

Saturday, May 11, 2019

মাইক্রোটিক রাউটারের কনফিগারেশন ব্যাকআপ এবং রিস্টোর প্রসেস

রাউটার এর কনফিগারেশন ফাইলগুলো Backup নেওয়টা প্রয়োজনীয়। কোন কারনে যদি আমাদের রাউটারটা ফেইল হয়ে যায় অথবা কেউ যদি আমাদের রাউটারের কনফিগারেশন সমুহ ডিলিট করে দেয় বা রাউটার ম্যাল ফাংশন করা শুরু করে তাহলে ব্যাকআপ করা ফাইল খুব সহজেই রিস্টোর করে আমরা আমাদের আগের কনফিগার সমুহ ফিরে পেতে পারি। আমাদের নেটওয়ার্ক এর নিরাপত্তার জন্য, নেটওয়ার্ক এর ডাউনটাইম কমানের জন্য আমরা প্রতিনিয়ত রাউটারের কনফিগারেশন সমুহের ব্যকআপ নিয়ে রাখা জরুরি।

ব্যাকআপ করার প্রয়োজনিয়তা

যদি কোন করণে আপনার রাউটারটি নষ্ট হয় আর যদি আপনার কাছে এই নষ্ট হওয়া রাউটারের ব্যাকআপ ফাইল থাকে তাহলে একটি নতুন MikroTik রাউটার কিনে সেই ব্যাকআপ ফাইলটি Upload এবং Restore করে কোনও ঝামেলা ছাড়াই আপনার রানিং নেটওয়ার্ক পাবেন। দুর্ভাগ্যবশত আপনি যদি আপনার মাইক্রোটিক রাউটারের অ্যাডমিন ইউজারের পাসওয়ার্ড ভুলে যান তখন তার রিকোভারি করার জন্য ব্যাকআপ ফাইলটি দরকার হবে।

রাউটারের কনফিগারেশন সমুহ ব্যাকআপ নেওয়া পদ্ধতি

Winbox এর মাধ্যমে কিভাবে মাইক্রোটিক রাউটারের কনফিগারেশন সমুহ ব্যাকআপ নিতে হয় একানে আমরা সেটাই দেখব। প্রথমে আমরা winbox এর মাধ্যমে মাইক্রোটিক রাউটরে লগিন করব।

STEP-1: মেনু থেকে File এ ক্লিক করুন। মেনু থেকে File এ ক্লিক করলে আমরা File List নামের একটি নতুন উইন্ডো দেখতে পাব। MikroTik রাউটারের ভিতরে কি কি ফাইল রয়েছে তা আমরা এখন থেকে দেখতে পাব। এখান থেকে আমরা চাইল এখান থেকে যে কোন ফাইলকে কপি করে নিতে পারব এবং আপলোডও করতে পারব।



STEP-2: File list এ উপরের দিকে Backup নামের একটি অপশন রয়েছে এখানে ক্লিক করব। Backup এ ক্লিক করলে আমারা Backup নামের একটি নতুন ইউন্ডো দেখতে পাব।

STEP-3: এখানে Name এর জায়গায় আমরা ব্যাকআপ ফাইলটির যে নাম দিতে চাই সেটি দিয়ে দিব এবং Password এর জায়গায় একটি পাসওয়ার্ড দিয়ে দিব এরপর Backup এ ক্লিক করব। যখন আমরা Backup এ ক্লিক করব তখনই File list এ আমাদের দেওয়া নামের একটি ব্যাকআপ ফাইল তৈরি হবে।

“এখানে যদি আমরা Name এবং Password এর জায়গায় কোন ইনফরমেশন না দেই তাহলে পাসওয়ার্ড ছাড়াই রানডম নামের একটি ব্যাকআপ ফাইল তৈরি হবে। আর যদি আমরা Name এবং Password দিয়ে দিই তাহলে পাসওয়ার্ড প্রোটেকটেড সেই নামের একটি ব্যাকআপ ফাইল তৈরি হবে।”

STEP-4: এর পর ফাইলটিকে সিলেক্ট করে ডাগ করে ডেক্সটপে নিয়ে ছেড়ে দিলে ফাইলটি কপি হয়ে ডেক্সটপে চলে যাবে। তাছাড়াও ফাইলটি সিলেক্ট করে আমরা File list উইন্ডোর উপরের দিকে একটি কপি আইকন দেখতে পাব সেখানে ক্লিক করলেই আমাদের ফাইলটি কপি হয়ে যাবে এবার ফাইলটি যেখানে পেষ্ট করতে চাই সেখানে পেষ্ট করলেই ফাইলটি কপি হবে।


এভাবেই আমরা মাইক্রোটিক রাউটারের কনফিগার সমুহকে ব্যাকআপ নিতে পারি।

ব্যাকআপ ফাইল রিস্টোর প্রসেস

এতক্ষন আমরা দেখলাম কিভাবে মাইক্রোটিক রাউটারের কনফিগার সমুকে ব্যাকআপ করতে হয়। এবার আমরা দেখব এই ব্যাকআপ ফাইলটিকে কিভাবে রিস্টোর করতে হয়। ধরুন কোন করনে আমাদের মাইক্রোটি রাউটারটি ফেইল হয়ে গিয়েছে এবং আমাদের মাইক্রোটিক রাউটারটি আর অন হচ্ছেনা। আমরা বাজার থেকে একটি নতুন মাইক্রোটিক রাউটার নিয়ে আসলাম। একটি নতুন রাউটার একদম ফ্রেশ সেখানে কোন ধরনের কনফিগার করা নেই।

স্বাভাবিক ভাবেই আমাদের নেটওয়ার্কটিকে রান করানোর জন্য আমাদের এই নতুন মাইক্রোটিক রাউটারটিক নতুন করে কনফিগার করতে হবে! কিন্তু আমাদের কাছে যেহেতু আগের রাউটারটির সকল কনফিগার সমুহ এর ব্যাকআপ নেওয়া আছে সেই ব্যাকআপ ফাইলটি রিস্টোর করে আমরা আগের নেটওয়ার্কটি সম্পূর্ণ রানিং অবস্থায় ফিরে পেতে পারি।

STEP-1: ব্যাকআপ ফাইলিটি রিস্টোর করার জন্য আমরা প্রথমে Winbox এর মাধ্যমে মাইক্রোটিক রাউটারে লগিন করাব তার পর মেনু থেকে File এ ক্লিক করব তাহলে আমাদের সামনে File list নামের একটি নতুন উইন্ডো আসবে।

এবার আমাদের যে ব্যাকআপ ফাইলটি রয়েছে সেটিকে ড্রাগ করে নিয়ে File list এর উপর ছেড়ে দিই। তাহলে দেখতে পাব ব্যাকআপ ফাইলটি File list এ চলে এসেছে। আমরা আরো এক ভাবে এই ফাইলটি এখানে নিয়ে আসতে পারি। তার জন্য আমরা ব্যাকআপ ফাইলটি কপি করব এবং এই File List এই উপরের দিকে একটি পেষ্ট আইকন দেখতে পাব। সেখানে ক্লিক করলেই আমাদের ব্যাকআপ ফাইলটি File list এ চলে আসবে।


STEP-2: এর পর ব্যাকআপ ফাইলটির উপরে মাউস ক্লিক করে ফাইলটি সিলেক্ট করি তার পর উপরের দিকে Restore নামের একটি অপশন দেখতে পাব সেখানে ক্লিক করি। Restore এ ক্লিক করলে আমাদের সামনে Restore নামের একটি নতুন উইন্ডো আসবে।


এখানে Pssword এর জায়গায় আমরা ব্যাকআপ ফাইলটির যে পাসওয়ার্ড দিয়েছিলাম তা দিয়ে Restore এ ক্লিক করি। Restore এ ক্লিক করলে কনফারমেশন এর জন্য আমাদের সমেনে একটি নটিফিকেশন আসবে। সেখানে Yes করি তাহলে আমাদের MikroTik Router টা রিবুট নিবে। এর পর সেটিতে লগিন করলে আমরা দেখতি পাব আগের রাউটারের সকল কনফিগারেশন ফিরে এসেছে।

এভাবেই মাইক্রোটিক রাউরে ব্যাকআপ এবং রিস্টোর করা হয়। আশা করি আপনারা বুঝতে পেরেছেন।

Monday, May 6, 2019

RIP (Routing Information Protocol) কনফিগারেশন

RIP কনফিগারেশন

রিপ সম্পর্কে আমরা আগেই জেনেছি যে  RIP রিপ হল Routing Information Protocol। রিপ একটি ডিস্টেন্স ভেক্টর রাউটিং প্রটোকল যা হপ কাউন্ট এর উপর ভিত্তি করে কাজ করে । ডিসট্যান্স ভেক্টর রাউটিং  প্রটোকলে এর  মাধ্যমে রাউটার জানতে পারে নেটওয়ার্কের প্রতিবেশী রাউটার সম্পর্কে । রিপ নিয়মিত নেটওয়ার্ক আপডেটের এডভার্টাইজমেন্ট করে এবং এই এডভার্টাইজমেন্ট  প্রতি 30 সেকেন্ড পাঠায় । এটি মেট্রিক মান গণনা করার জন্য হপ কাউন্ট ব্যবহার করে, যা নেটওয়ার্কের কাছে পৌঁছানোর সর্বোত্তম পথ নির্ধারণ করে। RIP সর্বোচ্চ 15 টি রাউটার সমর্থন করে, এবং 16 তম হপ বা রাউটার অপ্রচলিত বা অনির্ধারিত বলে বিবেচিত হয়। সুতরাং, RIP ছোট নেটওয়ার্কে দক্ষতার  সাথে কাজ করতে পারে ।

রিপ এর তিনটি সংস্করণ রয়েছে। IPv4 এ RIP V1 এবং RIP V2 সমর্থন করে , এবং RIPng বা RIP পরবর্তী প্রজন্ম IPv6 দ্বারা বাস্তবায়িত হয়। RIP V1 classfull নেটওয়ার্ককে advertises এবং সাবনেট সাপোর্ট করে না, কিন্তু RIP V2 একটি সাবনেটিং সাপোর্ট করে।

রিপ এর বৈশিষ্ট সমুহ:

  • রিপ একটি ডিস্টেন্স ভেক্টর রাউটিং প্রোটকল
  • ছোট নেটওয়ার্ক এর জন্য রিপ উপযোগি
  • রিপ প্রতি 30 সেকেন্ড পরপর তার রাউটিং টেবিল তার প্রতিবেশি রাউটার এর কাছে শেয়ার করে ।
  • রিপ ভার্সন 1 এ সাবনেটিং সাপোর্ট করে না তবে রিপ ভার্সন 2 তে সাবনেটিং সাপোর্ট করে ।
  • রিপ এর তিনটি সংকরণ রয়েছে যথা : RIP v1 RIP v2 RIPng
রিপ এর আগের পর্বে আমারা রিপ সম্পর্কে মোটামোটি অনেক কিছু জেনেছি । আমরা জেনিছি কিভাবে রিপ কাজ করে, রিপে কিভাবে রাউটিং লুপ সৃষ্টি হয় এবং তা কিভাবে এই লুপ প্রিভেনশন করা যায় তাও আমরা দেখেছি । লুপ প্রিভেনশন এর জন্য কি কি পদ্ধতি রয়েছে তাও আমরা দেখেছি । এবার আমরা দেখব কিভাবে রিপ কনফিগারেশন করা হয় ।

আমাদের প্রথেমে যে কাজটি করতে হবে তা হল, আমাদের একটি নেটওয়ার্ক ডিজাইন করতে হবে । আমরা এই কনফিগারেশন এর কাজগুলি করব সিসকোর একটি নিজস্ব সফটওয়্যার Cisco Packet Tracer এই সফটওয়্যারটি ই্উজ করে । নিচের চিত্রের দিকে খেয়াল করুন এখানে আমি একটি টপোলজি নিয়েছি যেখানে তিনটি রাউটার, প্রতিটি রাউটারের সাথে একটি করে সুইচ এবং প্রতিটি সুইচ এর সাথে একটি করে কম্পিউটার । এই রাউটার গুলিতে রিপ কনফিগার করে কিভাবে এই টপোলজিকে রান করতে হবে আমরা তাই দেখব ।

এখানে টোটাল 5টি ব্লক রয়েছে । প্রতিটি ব্লকে একটি করে নেটওয়ার্ক চলছে । এখানে প্রতিটি ব্লকে কি কি নেটওয়ার্ক চলছে তা আমি মেনশন করে দিয়েছি । আপনারা চাইলে যে কোন নেটওয়ার্ক নিয়ে কনফিগার করে দেখতে পারেন ।

এখন আমাদের প্রথমেই যে কাজটি হবে, তা হল রাউটারের প্রতিটি ইন্টারফেসে আইপি অ্যড্রেস দেওয়া। আমরা রাউটিং কেনসেপ্ট টিউটেরিয়ালে দেখেছি কিভাবে রাউটার এর ইন্টারফেসে আইপি অ্যাড্রেস ইমপ্লিমেন্ট করতে হয় । তারপরও আমি ইন্টারফেসে কিভাবে আইপি অ্যাড্রেস দিতে হয় তার কোডগুলিও দিয়ে দিলাম ।

Router 0: Router 0 তে মোট দুটি ইনটারফেস আছে একটি হল FastEthernet 0/0 এবং আর একটি Serial 0/0/0 । আপনাদের একটি বিষয় বলে রাখি রাউটার এর সিরিয়াল ইন্টাফেস গুলিতে একপাশে ক্লকরেট চালোতে হয় ।সিরিয়াল ক্যবল এর যেকোন একপশে ইন্টারফেস এর সাতে একটি ঘড়ির মত চিহ্ন থাকে, যে পাশে এই চিহ্ন থাকে সেই পাশে ক্লকরেট চালাতে হয় । অপর পাশে চালাতে হয় না । এখানে Router 0 এর Serial 0/0/0 এই ইন্টাফেস এ ক্লকরেট চালাতে হবে ।

Serial 0/0/0 Interface: Configuration Code
Router>en
Router#conf t
Router(config)#int se 0/0/0
Router(config-if)#ip add 10.0.0.1 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#no shut

Fast Ethernet 0/0 interface: Configuration Code
Router>
Router>en
Router#conf t
Router(config)#int fa 0/0
Router(config-if)#ip add 192.168.30.1 255.255.255.0
Router(config-if)#no shut

Router 1: রাউটার ১ এ তিনটি ইন্টারফেস রয়েছে । এই ইন্টারফেস সমুহ হল Serial 0/0/0, Serial 0/0/1 এবং FastEthernet 0/0। এই তিনটি ইন্টারফেসে তিনটি নেটওয়ার্ক চলছে । Serial 0/0/0 রয়েছে Block A তে, যেখানে নেটওয়ার্ক চলে 10.0.0.0/30, যার সাবনেট মাক্স হল 255.255.255.252।  Serial 0/0/1 রয়েছে Block B তে, যেখানে নেটওয়ার্ক চলে 20.0.0.0/30, যার সাবনেট মাক্স 255.255.255.252 এবং ইন্টারফেস Fast Ethernet Fa 0/0 রয়েছে Block D তে, যেখানে নেটওয়ার্ক চলে 192.168.20.0/24 যার সাবনেট মাক্স 255.255.255.0। চলুন এবার দেখি কিভাবে এই ইন্টারফেসগুলিতে এই আইপি অ্যাড্রেস সমুহ ইমপ্লিমেন্ট করতে হয় ।

Interface Serial 0/0/0 Configuration Code
Router>
Router>en
Router#conf t
Router(config)#interface se 0/0/0
Router(config-if)#ip add 10.0.0.2 255.255.255.252
Router(config-if)#no shut

Interface Serial 0/0/1 Configuration Code
Router>en
Router#conf t
Router(config)#interface se 0/0/1
Router(config-if)#ip add 20.0.0.2 255.255.255.252
Router(config-if)#no shutdown

Inteface FastEthernet Fa 0/0 Configuration Code
Router>en
Router#conf t
Router(config)#interface fa 0/0
Router(config-if)#ip add 192.168.20.1 255.255.255.0
Router(config-if)#no shut

Router 2: রাউটার ১ এ দুইটি ইন্টারফেস রয়েছে । এই ইন্টারফেস সমুহ হল Serial 0/0/0 এবং FastEthernet 0/0। এই দুইট ইন্টারফেসে দুইটি নেটওয়ার্ক চলছে । Serial 0/0/0 রয়েছে Block B তে, যেখানে নেটওয়ার্ক চলে 20.0.0.0/30, যার সাবনেট মাক্স হল 255.255.255. এবং ইন্টারফেস Fast Ethernet Fa 0/0 রয়েছে Block C তে, যেখানে নেটওয়ার্ক চলে 192.168.10.0/24 যার সাবনেট মাক্স 255.255.255.0। চলুন এবার দেখি কিভাবে এই ইন্টারফেসগুলিতে এই আইপি অ্যাড্রেস সমুহ ইমপ্লিমেন্ট করতে হয় ।         

Interface Serial 0/0/0 Configuration Code
Router>
Router>en
Router#conf t
Router(config)#int se 0/0/0
Router(config-if)#ip address 20.0.0.1 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown

Inteface FastEthernet Fa 0/0 Configuration Code
Router>en
Router#conf t
Router(config)#interface fa 0/0
Router(config-if)#ip add 192.168.10.1 255.255.255.0
Router(config-if)#no shut

আমরা তিনটি রাউটারের সকল ইন্টারফেসে নেটওয়ার্ক গুলি ইমপ্লিমেন্ট করলাম। কিভাবে ইন্টারফেস গুলিতে আইপি অ্যাড্রেস দিতে তা দেখলাম । এবার দেখব কিভাবে রাউটারে রিপ চালাতে হয় । একটি বিষয় বলে রাখি. রিপ বা কোন রাউটিং প্রোটকল কিন্তু রাউটারের কোন ইন্টারফেসে চলে না । রাউটিং প্রোটকল সমুহ রাউটারে চলে । নিচে তিনটি রাউটারে কিভাবে রিপ চালাতে হবে তার কোড সমুহ দেওয়া হল । আমরা এখানে RIPv2 ব্যবহার করব। কেননা RIPv1 সাবনেটিং সাপোর্ট করে না। এই টপোলজিটিতে আমরা যেহেতু সাবনেটিং করেছি তাই আমরা RIPv2 ব্যবহার করব।

# Router 0 Configuration Code
Router>en
Router#conf t
Router(config)#router rip
Router(config-router)#ver
Router(config-router)#version 2
Router(config-router)#network 192.168.30.0
Router(config-router)#network 10.0.0.0
Router(config-router)#do wr
Building configuration...
[OK]

এখানে আমরা শুধু ডাইরেক্টলি কানেকটেড নেটওয়ার্ক গুলিকে ইমপ্লিমেন্ট করে দিলাম। এই (Router(config-router)#do wr) do wr কোডটির মাধ্যমে এই কনফিগারেশটিকে আমরা সেভ করলাম।

#Router 1 Configuration Code
Router>en
Router#conf t
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 10.0.0.0
Router(config-router)#network 192.168.20.0
Router(config-router)#network 20.0.0.0
Router(config-router)#do wr
Building configuration...
[OK]

# Router 2 Configuration Code
Router>en
Router#conf t
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.10.0
Router(config-router)#network 20.0.0.0
Router(config-router)#do wr
Building configuration...
[OK]

এবার যদি আমরা রাউটারে ‍ Privilege mode এ গিয়ে "sh ip route" এই কমান্ডটি চালাই তাহলে আমরা রাউটার এ কি কি রুট রয়েছে তা দেখতে পাব । আমাদের এই টপোলজিতে মোট ৫টি নেটওয়ার্ক আছে । যদি অমাদের কোন কনফিগারেশন এ ভুল না হয় তাহলে আমরা দেখতে পাব যে প্রতিটি রাউটারে এই ৫টি রুট রয়েছে। চলুন এই কমান্ডটি চালিয়ে দেখি

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
R 20.0.0.0/8 [120/1] via 10.0.0.2, 00:00:02, Serial0/0/0
R 192.168.10.0/24 [120/2] via 10.0.0.2, 00:00:02, Serial0/0/0
R 192.168.20.0/24 [120/1] via 10.0.0.2, 00:00:02, Serial0/0/0
C 192.168.30.0/24 is directly connected, FastEthernet0/0

আপনারা দেখতে পাচ্ছেন এখান ৫টি নেটওয়ার্ক চলে এসেছে । এখানে প্রতিটি রুট এর আগে C or R রয়েছে । এই C দ্বারা বুঝায় এটি ডাইরেক্টলি কানেকডেট নেটওয়ার্ক এবং R দ্বরা বুঝায় এই রুটটি রিপ এর মাধ্যমে এসেছে ।